Copyright Agreement

The purchase and use of all Software and Services is subject to the Agreement as defined in Kaseya’s “Click-Accept” EULATOS as updated from time to time by Kaseya at http://www.kaseya.com/legal.aspx. If Customer does not agree with the Agreement, please do not install, use or purchase any Software and Services from Kaseya as continued use of the Software or Services indicates Customer’s acceptance of the Agreement.”
Contents
# Contents

Introduction........................................................................................................................................... i
Prerequisites........................................................................................................................................ i
Installation.......................................................................................................................................... i

## Setup Wizard Configuration

- QuoteWerks Configuration .................................................................................................................. ii
- Set the Access Key............................................................................................................................... iii
- Setup BMS Credentials....................................................................................................................... vi

## QuoteWerks Configuration

- BMS Services Menu Item ..................................................................................................................... vi
- Contact Manager Setup...................................................................................................................... ix

## Usage Guide

- Tray Icon............................................................................................................................................ 11
- Settings............................................................................................................................................. 11
- BMS Contact Manager ....................................................................................................................... 14
- BMS Service Manager ....................................................................................................................... 15
- Saving Quotations............................................................................................................................... 16
  - Quotation Transfer Process ............................................................................................................. 17
  - Opportunity Creation/Update .......................................................................................................... 18
  - Follow Up Activity Creation/Update............................................................................................... 18
- Converting Quotations........................................................................................................................ 18
Introduction

This guide documents how to install and use the QuoteWerks Connector tool, developed to integrate BMS with QuoteWerks.

Prerequisites

The following applications and libraries are required to ensure smooth installation and usage on the target machine.

- Windows Vista and above
  - Only a licensed version will work with QuoteWerks Connector.
  - QuoteWerks must run in administrative mode
  - A BMS username assigned the Administrator role.

Installation

1. Open the Home > Downloads page in BMS.
2. Locate the QuoteWerks Connector integration tool and click Download.
3. Run the setup file (QNConnectorSetup.msi).
4. Accept the license agreement and click Install.
Once installation is complete the following window displays.

5. Click Finish to launch **BMS QuoteWerks Connector**.

### Setup Wizard Configuration
This section describes how to configure the integration between BMS and QuoteWerks.

### QuoteWerks Configuration
The first time the **QuoteWerks Connector** application runs, a setup wizard attempts to locate an existing QuoteWerks installation on the target machine.
The setup wizard attempts to start QuoteWerks if it is not found running. Once started and logged in, setup continues processing configuration parameters, then displays its success status.

Initial QuoteWerks configuration is complete. Click the **Next** button.

**Set the Access Key**

After the initial configuration the setup wizard prompts you to specify an access key. The key provides access to the QuoteWerks API.
1. Enter any string you want. If the access key entered does not already exist, the wizard automatically registers it in QuoteWerks.

2. A prompt displays, instructing you how to approve the key in QuoteWerks to grant access.

3. A second prompt tells you your access key is pending approval.
4. To approve the access key, open the QuoteWerks > Tools > Options window.

5. Select the Security tab.

6. Locate the API Access group box.

   You will see your access key added to the list, with an access level of Pending Approval.

7. Select this item and click the Edit button.

8. Change the access level to Full, then click Ok.

9. Click Ok on the options window to confirm the changes.

   The access key has been approved.

10. Verify approval by returning to the setup wizard and clicking the Validate Access button.
Setup BMS Credentials

The setup wizard then prompts the user to specify the credentials of the BMS account to use when integrating with QuoteWerks.

1. First, specify the server URL where your account is hosted. For example:
   - https://psa.pulseway.com
   - https://psaemea.pulseway.com
   - https://www.vorexlogin.com

2. Then enter the tenant name, username and password.

   **Note:** The Kaseya® BMS™ username must be assigned the Administrator role.

3. Click Test to verify connection to the account is successful.

QuoteWerks Configuration

The following configuration steps are required in QuoteWerks. These cannot be automated by the setup wizard.

BMS Services Menu Item

In this step you add a new custom menu option to the QuoteWerks application. The new menu option is used to open the BMS Services Manager window from within QuoteWerks.
1. Select the Tools > Customize Menus… menu item.

![Customize Menus](image)

2. Select Products Menu.
4. Click New.
5. Enter the following in the Create New Product Menu Item window.
   - **Caption** - BMS Services
   - **Action** - Run External Application
   - **Command** - C:\Program Files (x86)\Kaseya\QWConnector\QWConnector.exe -p
     The command points to the location of the QuoteWerks Connector application executable. The -p parameter indicates the application is open to the services window.

![Create New Product Menu Item](image)

6. Click OK to save your changes.
   You must now publish the new menu item you just created.
7. Select the **Publish Menu Items** button on the **Customize Menus** window.

![Customize Menus Window](image1)

8. Click **Add** to add the new menu item to the **Products Menu**.

![Products Menu Window](image2)

9. Click **Select** for the menu item you just created.

![Select Menu Item Window](image3)

Your new menu item has been published.
10. Select it from the QuoteWerks toolbar.

**Contact Manager Setup**

In this step you instruct QuoteWerks to use the BMS Contact Manager when selecting the contact for a quotation.

1. Select **Contacts** in the toolbar menu.
2. Select **Setup Contact Manager**. A list of options displays.
3. Select **Kaseya BMS (3rd party)** from the list.
4. Click **Ok**.

---

**Introduction**

**Prerequisites**

**Installation**

**Setup Wizard Configuration**

**QuoteWerks Configuration**

**Set the Access Key**
Setup BMS Credentials ................................................................. vi
QuoteWerks Configuration ............................................................ vi
BMS Services Menu Item .............................................................. vi
Contact Manager Setup .............................................................. ix
Usage Guide .............................................................................. 11
  Tray Icon .............................................................................. 11
  Settings ................................................................................. 11
BMS Contact Manager ................................................................ 14
BMS Service Manager ............................................................... 15
Saving Quotations ...................................................................... 16
  Quotation Transfer Process ....................................................... 17
  Opportunity Creation/Update .................................................... 18
  Follow Up Activity Creation/Update ........................................... 18
Converting Quotations ............................................................... 18
Usage Guide

This section describes how to use the QuoteWerks tool.

Tray Icon

When the QuoteWerks application starts, the QuoteWerks Connector tool starts automatically. The system tray displays a Kaseya icon.

The user can right click the icon to access various options:

- **Service Manager** - Open the BMS service manager.
- **Contact Manager** - Opens the BMS contact manager.
- **Settings** - Sets QuoteWerks Connector options.
- **Help**
  - About
  - Check for Updates
- **Exit**

Settings

Clicking the **Settings** option on the QuoteWerks Connector system tray icon displays the **Settings** window. Options include:

- Revising the authentication and security parameters defined while initially setting up the QuoteWerks integration tool.
- Changing the server URL and tenant credentials, in addition to validating access to the QuoteWerks application backend API.

On the Mapping tab, you can configure advanced mapping options:
- Map QuoteWerks item types compared to BMS.
- Set Default Statuses for created opportunities.
- Set the option to save QuoteWerks quotations automatically in BMS.
By default, item types in QuoteWerks map to products in BMS automatically.

- **QuoteWerks Connector** checks for an item type while creating a quote in BMS. Products defined in the BMS inventory are checked to see if the item already exists. If not found, the item is created automatically in BMS as a product.
- You can change this default behavior by clicking the **Map Item Type** button.

In the second part of the mapping tab, the user can set the mapping defaults for opportunity statuses. BMS opportunities can be created or updated when saving or converting a quotation in QuoteWerks. The drop-downs mapped to each QuoteWerks status—open, lost, won—show the possible values to map to in BMS.

On the **Product Mappings** tab, you can configure advance product mapping options:

- Map QuoteWerks item types compared to BMS.
- Map Product Name for created product to BMS.
- Map Product Number for created product to BMS.

**Note:** "Product Name" and "Product Number" are required fields in BMS, these fields have to be filled with information in the Quote in QuoteWerks.

- Set Product UPC for created product to BMS.
- Set Product SKU for created product to BMS.

**BMS Contact Manager**

The Contact Manager enables users to select a BMS CRM account contact from within QuoteWerks and add it to a quote.
To access the **Contact Manager** window the user can:

- Click the contact or filter buttons in the **Sold To/Ship To** tab of the quotation being worked on.
- Use the context menu of the system **tray icon** (page 11).

  - The list of contacts can be filtered by account name, first and last name, and other details.
  - A contact is classified in the **use for** section, as **Sold To**, **Ship To**, **Bill To** or all three.

**Note:** Successful transfer of a quotation into BMS at a later stage requires a **Sold To** contact.

---

**BMS Service Manager**

The **Service Manager** enables users to add BMS services to a quotation in QuoteWerks.

**Note:** See **BMS Services Menu Item** (page vi) to configure this integration.

To access the **Service Manager** window:
- Use the menu item of the tray icon (page 11) context menu.

![Lookup Services window](image)

- Use this window to search for BMS defined services, set the required quantity, then add them to the list of items defined in the quotation.

**Note:** Adding the same item multiple times adds separate line items to the quotation, each with its own quantity.

### Saving Quotations

Saving a quotation in QuoteWerks can optionally transfer the quotation into BMS. Saving the quotation will also create or update opportunities and followup activities in BMS.

**Note:** This process only occurs if the Save to BMS on Saving Quote checkbox is checked in the Settings (page 11) > Mapping tab. If not checked, transfer occurs when the quote is converted in QuoteWerks.
Quotation Transfer Process

Once a user is satisfied with the items and details of a quote in QuoteWerks, the quotation is saved. When integrated with BMS a small popup displays just after the save. The popup enables you to select two options for this particular transfer:

- **Create/Update Sales Opportunity**
- **Create/Update Follow up Activity**

The transfer starts after clicking **OK**. The quotation is generated within BMS and includes all product and service line items from the QuoteWerks quotation. Any products or services that do not already exist in BMS are automatically created.
Opportunity Creation/Update

If the Create/Update Sales Opportunity checkbox was checked, the Opportunity window below displays.

Use this window to update an existing opportunity or create a new one. Enter data in the appropriate fields and click Save.

Follow Up Activity Creation/Update

If the Create/Update Follow up Activity checkbox was checked, the Create Activity window below displays.

Use this window to update an existing followup activity or create a new one. Enter data in the appropriate fields and click Save.

This followup activity will be linked to both the created or updated opportunity and to the created or updated quotation. The followup activity will be added to the calendar of the assigned employee.

Converting Quotations

When QuoteWerks converts a quotation into an order the corresponding CRM quotation in BMS is marked as accepted. BMS users can then convert the order into projects, contracts, and sales orders. To convert a QuoteWerks quotation to an order:
1. Select the File > Convert To Order sub menu.

A Convert Quote popup window displays. This window allows users to specify whether this quotation was won or lost, and set other QuoteWerks related properties.

2. Click OK to trigger the same workflow as saving a quotation (page 16). Differences include:
   - Related opportunities will be marked as Won or Lost.
   - The probability of related opportunities will be set to 100% or 0% based on whether the opportunity was Won or Lost.
The quotation in BMS will have the status Accepted.